Copyright © 2026 MijnKlantportaal
A service and trade name of Brewbit.
Resolved
The issue has been resolved
Monitoring
We have implemented a fix and now monitoring the result.
Identified
We have found the issue and working on a fix.
Investigating
It's currently not possible to create new users for your customers. We are investigating the issue.