Copyright © 2026 MijnKlantportaal
A service and trade name of Brewbit.
Resolved
The issue has been resolved.
Monitoring
We have implemented the fix and monitoring the results now.
Identified
We have found the issue and working on a fix.
Investigating
Currently, we are experiencing issues with downloading files in the managing portal. We are investigating the issue.