Copyright © 2026 MijnKlantportaal
A service and trade name of Brewbit.
Resolved
The fix is implemented and the issue is resolved.
Identified
We have identified the issue and working on a fix.
Investigating
At the moment, we experience issues with creating invoices in Acumulus administrations. We are investigating the issue.
Importing invoices and customers are not effected, as well as other integrations.