Copyright © 2026 MijnKlantportaal
A service and trade name of Brewbit.
Resolved
The problem has been resolved.
Monitoring
We have identified the issue and deployed a fix. The results are currently being monitored.
Investigating
We are seeing an increased rate of errors for the public file request pages. We are investigating the issue.