Copyright © 2026 MijnKlantportaal
A service and trade name of Brewbit.
No components marked as affected
Resolved
The incident has been resolved
Identified
the issue is partially resolved. Valid VAT-numbers can be saved again. In case of an invalid number, an unrecoverable error is still shown.
Identified
Due to an issue at our external VAT-number validation provider, you can not add or modify this info in the Managing portal.