Copyright © 2026 MijnKlantportaal
A service and trade name of Brewbit.
No components marked as affected
Resolved
The issue has been resolved.
Monitoring
A fix has been deployed and we are verifying the results.
Investigating
Due to an issue, the License & Invoice page will not load or return an error. We are investigating the issue.